This has bothered me for quite some time with Windows 7 initiating the startup repair option when I know my OS is in good working order. Most times it is because my machine is overclocked and Esata devices and such are plugged in during shutdown. Even after enabling AHCI in the bios was still getting the startup repair option from time to time so in order to disable just follow these instructions:

Open command prompt and enter the following command

bcdedit /set {default} bootstatuspolicy ignoreallfailures

To restore the startup option, run below command

bcdedit /set {default} bootstatuspolicy displayallfailures

Note: if you had enabled UAC then run the cmd as administrator

Thanks to my friend Ben