Results 1 to 3 of 3

Thread: TLS security settings Share

  1. #1
    IcicleThief69 is offline
    Skilled


    Join Date
    Jan 2012
    Location
    Spring Hill Florida
    Posts
    123
    Mentioned
    0 Post(s)
    Tagged
    27 Thread(s)


    Sex:

    TLS security settings

    I'm having problems with this message,

    Can’t connect securely to this page

    This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.


    This is really a BIG pain my side right now for the past few days, everything I have looked up to fix this has not worked. What is happening is that when I try to open Google.com it does not open. But all my other sites open for browsing but when I go to some for downloading the buttons will not show up right. Is this a windows 10 update issue?

    Here's what my computer is running right now

    Windows 10 Home
    Version 1803
    Installed on 5/22/2018
    OS build 17134.228


    I have even tried to roll back to a point over a month ago to fix it but that won't work ether. If anyone has a fix that will fix this for sure please help.

    Thank You
    Reply With Quote Reply With Quote

  2. #2
    Dark Knight is offline
    VC Ambassador



    Join Date
    Aug 2011
    Location
    Atlanta, Georgia
    Age
    54
    Posts
    1,283
    Mentioned
    3 Post(s)
    Tagged
    254 Thread(s)


    Sex:
    Quote Originally Posted by IcicleThief69 View Post
    I'm having problems with this message,

    Can’t connect securely to this page

    This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.


    This is really a BIG pain my side right now for the past few days, everything I have looked up to fix this has not worked. What is happening is that when I try to open Google.com it does not open. But all my other sites open for browsing but when I go to some for downloading the buttons will not show up right. Is this a windows 10 update issue?

    Here's what my computer is running right now

    Windows 10 Home
    Version 1803
    Installed on 5/22/2018
    OS build 17134.228


    I have even tried to roll back to a point over a month ago to fix it but that won't work ether. If anyone has a fix that will fix this for sure please help.

    Thank You
    First I have heard of it, I don't think this is a Windows Update Issue, I think it may be a IcicleThief69 issue. You may have changed something or installed something that changed a setting and the first mistake you made is relying on a Windows restore point, don't worry, I have made that mistake too, but TOOO many times Windows Restore points do absolutely nothing for you and I had to learn the hard way also.

    Sorry to say but the best bet for you if you cannot find the fix is to do a refresh, if that does not work then a complete re-install.

    Then when you are done the first thing you do is invest in a backup program, Macrium Reflect free or paid works VERY well.

    If you want go one step further and take regular snapshots of your system at regular intervals which is a good idea also, stay away from Rollback Rx, first HorizonData Sys are thieves and second the program will suck on your system resources like a calf on it's mothers tit, Flashback BY Xeroweight (Used to be X64) is a much better program, cheaper and lighter on your system and it works.

    Good luck, let us know how you make out.
    Last edited by Dark Knight; 09-02-2018 at 09:10 PM.


    Visit My Deviant Art Page : http://darkknight2264.deviantart.com/






    I believe in karma which means I can say all the bad things I want to you and just assume that you deserve it.



    Reply With Quote Reply With Quote

  3. #3
    IcicleThief69 is offline
    Skilled


    Join Date
    Jan 2012
    Location
    Spring Hill Florida
    Posts
    123
    Mentioned
    0 Post(s)
    Tagged
    27 Thread(s)


    Sex:
    Got it fixed, like you said I had to do a refresh install of wondows. i still don't know what was cuasing the problem. But from what I read online I'm not the only to have this problem. But after doing a refresh install of windows 10 everything is back to normal and I did not lose anything none of my programs ether.

    Thanks for the help, can always find good help on here.
    Reply With Quote Reply With Quote


 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 12-20-2016, 01:00 PM
  2. Stardock settings not saving
    By I Hunt Demons in forum Software
    Replies: 2
    Last Post: 05-10-2012, 02:26 AM
  3. Optimal Playable Settings for SLI
    By Feed Monkey in forum GeForce.com
    Replies: 0
    Last Post: 01-12-2012, 09:01 AM
  4. Windows Security Troubleshooter: Fix Windows security proble
    By razorsedge in forum News & Reviews
    Replies: 0
    Last Post: 10-27-2010, 03:52 AM
  5. Tweak Windows 7 Alt-Tab Settings
    By razorsedge in forum Windows tweaking and Management Apps
    Replies: 0
    Last Post: 08-05-2010, 07:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •